10/11/54

MPLS_PE_Router of DMVPN Customer Project.

Configuration of MPLS_PE_Router of DMVPN Customer Project. 

     As below it will be configuration of MPLS_PE_Router as we configure by using vrf "DMVPN" for being section VPN of this customer.

MPLS-PE-1 ************************************************

hostname PE1
!
ip cef
!
ip vrf DMVPN
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
mpls label protocol ldp
mpls ldp neighbor 10.1.1.11 password cisco
mpls ldp neighbor 10.1.1.22 password cisco
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Loopback10
 ip vrf forwarding DMVPN
 ip address 10.10.10.1 255.255.255.255
!
interface Ethernet1/0
 description # To P1 e1/0 #
 ip address 192.168.1.2 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet1/1
 description # To P2 e1/0 #
 ip address 192.168.1.34 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet1/2
 ip vrf forwarding DMVPN
 ip address 10.1.1.9 255.255.255.252
!
router ospf 10 vrf DMVPN
 log-adjacency-changes
 redistribute bgp 100 subnets
 network 10.1.1.9 0.0.0.0 area 0
!
router ospf 1
 router-id 10.1.1.1
 log-adjacency-changes
 max-metric router-lsa on-startup wait-for-bgp
 max-metric router-lsa on-startup 360
 timers throttle lsa all 0 20 5000
 timers lsa arrival 15
 timers pacing flood 15
 timers throttle spf 50 50 5000
 ispf
 area 0 authentication message-digest
 network 10.1.1.1 0.0.0.0 area 0
 network 192.168.1.2 0.0.0.0 area 0
 network 192.168.1.34 0.0.0.0 area 0
!
router bgp 100
 bgp log-neighbor-changes
 neighbor 10.1.1.11 remote-as 100
 neighbor 10.1.1.11 password cisco
 neighbor 10.1.1.11 update-source Loopback0
 neighbor 10.1.1.22 remote-as 100
 neighbor 10.1.1.22 password cisco
 neighbor 10.1.1.22 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.1.1.11 activate
 neighbor 10.1.1.11 send-community
 neighbor 10.1.1.22 activate
 neighbor 10.1.1.22 send-community
 no auto-summary
 no synchronization
 network 10.1.1.1 mask 255.255.255.255
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.1.1.11 activate
 neighbor 10.1.1.11 send-community extended
 neighbor 10.1.1.22 activate
 neighbor 10.1.1.22 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf DMVPN
 redistribute ospf 10 vrf DMVPN match internal external 1 external 2
 no synchronization
 exit-address-family
!
mpls ldp router-id Loopback0 force
!



MPLS-PE-2 ************************************************

hostname PE2
!
ip cef
!
ip vrf DMVPN
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
mpls label protocol ldp
mpls ldp neighbor 10.1.1.11 password cisco
mpls ldp neighbor 10.1.1.22 password cisco
!
interface Loopback0
 ip address 10.1.1.2 255.255.255.255
!
interface Loopback10
 ip vrf forwarding DMVPN
 ip address 10.10.10.2 255.255.255.255
!
interface Ethernet1/0
 description # To P1 e1/1 #
 ip address 192.168.1.6 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 half-duplex
 mpls ip
!
interface Ethernet1/1
 description # To P2 e1/1 #
 ip address 192.168.1.38 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 half-duplex
 mpls ip
!
interface Ethernet1/2
 ip vrf forwarding DMVPN
 ip address 10.1.1.13 255.255.255.252
 half-duplex
!
router ospf 10 vrf DMVPN
 log-adjacency-changes
 redistribute bgp 100 subnets
 network 10.1.1.13 0.0.0.0 area 0
!
router ospf 1
 router-id 10.1.1.2
 log-adjacency-changes
 max-metric router-lsa on-startup wait-for-bgp
 max-metric router-lsa on-startup 360
 timers throttle lsa all 0 20 5000
 timers lsa arrival 15
 timers pacing flood 15
 timers throttle spf 50 50 5000
 ispf
 area 0 authentication message-digest
 network 10.1.1.2 0.0.0.0 area 0
 network 192.168.1.6 0.0.0.0 area 0
 network 192.168.1.38 0.0.0.0 area 0
!
router bgp 100
 bgp log-neighbor-changes
 neighbor 10.1.1.11 remote-as 100
 neighbor 10.1.1.11 password cisco
 neighbor 10.1.1.11 update-source Loopback0
 neighbor 10.1.1.22 remote-as 100
 neighbor 10.1.1.22 password cisco
 neighbor 10.1.1.22 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.1.1.11 activate
 neighbor 10.1.1.11 send-community
 neighbor 10.1.1.22 activate
 neighbor 10.1.1.22 send-community
 no auto-summary
 no synchronization
 network 10.1.1.2 mask 255.255.255.255
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.1.1.11 activate
 neighbor 10.1.1.11 send-community extended
 neighbor 10.1.1.22 activate
 neighbor 10.1.1.22 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf DMVPN
 redistribute ospf 10 vrf DMVPN match internal external 1 external 2
 no synchronization
 exit-address-family
!
mpls ldp router-id Loopback0 force
!



MPLS-PE-8 ************************************************

hostname PE8
!
ip cef
!
ip vrf DMVPN
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
!
mpls label protocol ldp
mpls ldp neighbor 10.1.1.11 password cisco
mpls ldp neighbor 10.1.1.22 password cisco
!
interface Loopback0
 ip address 10.1.1.8 255.255.255.255
!
interface Loopback10
 ip vrf forwarding DMVPN
 ip address 10.10.10.8 255.255.255.255
!
interface Ethernet1/0
 description # To P1 e2/0 #
 ip address 192.168.1.18 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 half-duplex
 mpls ip
!
interface Ethernet1/1
 description # To P2 e2/0 #
 ip address 192.168.1.50 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 half-duplex
 mpls ip
!
interface Ethernet1/2
 ip vrf forwarding DMVPN
 ip address 10.1.1.1 255.255.255.252
 half-duplex
!
interface Ethernet1/3
 ip vrf forwarding DMVPN
 ip address 10.1.1.5 255.255.255.252
 half-duplex
!
router ospf 10 vrf DMVPN
 log-adjacency-changes
 redistribute bgp 100 subnets
 network 10.1.1.1 0.0.0.0 area 0
 network 10.1.1.5 0.0.0.0 area 0
!
router ospf 1
 router-id 10.1.1.8
 log-adjacency-changes
 max-metric router-lsa on-startup wait-for-bgp
 max-metric router-lsa on-startup 360
 timers throttle lsa all 0 20 5000
 timers lsa arrival 15
 timers pacing flood 15
 timers throttle spf 50 50 5000
 ispf
 area 0 authentication message-digest
 network 10.1.1.8 0.0.0.0 area 0
 network 192.168.1.18 0.0.0.0 area 0
 network 192.168.1.50 0.0.0.0 area 0
!
router bgp 100
 bgp log-neighbor-changes
 neighbor 10.1.1.11 remote-as 100
 neighbor 10.1.1.11 password cisco
 neighbor 10.1.1.11 update-source Loopback0
 neighbor 10.1.1.22 remote-as 100
 neighbor 10.1.1.22 password cisco
 neighbor 10.1.1.22 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.1.1.11 activate
 neighbor 10.1.1.11 send-community
 neighbor 10.1.1.22 activate
 neighbor 10.1.1.22 send-community
 no auto-summary
 no synchronization
 network 10.1.1.8 mask 255.255.255.255
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.1.1.11 activate
 neighbor 10.1.1.11 send-community extended
 neighbor 10.1.1.22 activate
 neighbor 10.1.1.22 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf DMVPN
 redistribute ospf 10 vrf DMVPN match internal external 1 external 2
 no synchronization
 exit-address-family
!
mpls ldp router-id Loopback0 force
!

MPLS CORE ROUTER (P-1 and P-2)

MPLS CORE ROUTER (P-1 and P-2)

^_^  Setup network connection as last Network Diagram, we use LDP for MPLS label in this Lab. All configurations of MPLS Core Router as below. For fast recovery of OSPF, we use little advanced timer and then tune a little for suitable with real world.


MPLS-P-1 ************************************************

!
ip cef
!
mpls label protocol ldp
mpls ldp neighbor 10.1.1.1 password cisco
mpls ldp neighbor 10.1.1.2 password cisco
mpls ldp neighbor 10.1.1.3 password cisco
mpls ldp neighbor 10.1.1.4 password cisco
mpls ldp neighbor 10.1.1.5 password cisco
mpls ldp neighbor 10.1.1.6 password cisco
mpls ldp neighbor 10.1.1.7 password cisco
mpls ldp neighbor 10.1.1.8 password cisco
!
interface Loopback0
 ip address 10.1.1.11 255.255.255.255
!
interface Ethernet1/0
 description # To PE1 e1/0 #
 ip address 192.168.1.1 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet1/1
 description # To PE2 e1/0 #
 ip address 192.168.1.5 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet1/2
 description # To PE3 e1/0 #
 ip address 192.168.1.9 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet1/3
 description # To PE4 e1/0 #
 ip address 192.168.1.13 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet2/0
 description # To PE8 e1/0 #
 ip address 192.168.1.17 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet2/1
 description # To PE7 e1/0 #
 ip address 192.168.1.21 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet2/2
 description # To PE6 e1/0 #
 ip address 192.168.1.25 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet2/3
 description # To PE5 e1/0 #
 ip address 192.168.1.29 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
router ospf 1
 router-id 10.1.1.11
 log-adjacency-changes
 max-metric router-lsa on-startup wait-for-bgp
 max-metric router-lsa on-startup 360
 timers throttle lsa all 0 20 5000
 timers lsa arrival 15
 timers pacing flood 15
 timers throttle spf 50 50 5000
 ispf
 area 0 authentication message-digest
 network 10.1.1.11 0.0.0.0 area 0
 network 192.168.1.1 0.0.0.0 area 0
 network 192.168.1.5 0.0.0.0 area 0
 network 192.168.1.9 0.0.0.0 area 0
 network 192.168.1.13 0.0.0.0 area 0
 network 192.168.1.17 0.0.0.0 area 0
 network 192.168.1.21 0.0.0.0 area 0
 network 192.168.1.25 0.0.0.0 area 0
 network 192.168.1.29 0.0.0.0 area 0
!
router bgp 100
 bgp cluster-id 12
 bgp log-neighbor-changes
 neighbor 10.1.1.1 remote-as 100
 neighbor 10.1.1.1 password cisco
 neighbor 10.1.1.1 update-source Loopback0
 neighbor 10.1.1.2 remote-as 100
 neighbor 10.1.1.2 password cisco
 neighbor 10.1.1.2 update-source Loopback0
 neighbor 10.1.1.3 remote-as 100
 neighbor 10.1.1.3 password cisco
 neighbor 10.1.1.3 update-source Loopback0
 neighbor 10.1.1.4 remote-as 100
 neighbor 10.1.1.4 password cisco
 neighbor 10.1.1.4 update-source Loopback0
 neighbor 10.1.1.5 remote-as 100
 neighbor 10.1.1.5 password cisco
 neighbor 10.1.1.5 update-source Loopback0
 neighbor 10.1.1.6 remote-as 100
 neighbor 10.1.1.6 password cisco
 neighbor 10.1.1.6 update-source Loopback0
 neighbor 10.1.1.7 remote-as 100
 neighbor 10.1.1.7 password cisco
 neighbor 10.1.1.7 update-source Loopback0
 neighbor 10.1.1.8 remote-as 100
 neighbor 10.1.1.8 password cisco
 neighbor 10.1.1.8 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.1.1.1 activate
 neighbor 10.1.1.1 send-community
 neighbor 10.1.1.1 route-reflector-client
 neighbor 10.1.1.2 activate
 neighbor 10.1.1.2 send-community
 neighbor 10.1.1.2 route-reflector-client
 neighbor 10.1.1.3 activate
 neighbor 10.1.1.3 send-community
 neighbor 10.1.1.3 route-reflector-client
 neighbor 10.1.1.4 activate
 neighbor 10.1.1.4 send-community
 neighbor 10.1.1.4 route-reflector-client
 neighbor 10.1.1.5 activate
 neighbor 10.1.1.5 send-community
 neighbor 10.1.1.5 route-reflector-client
 neighbor 10.1.1.6 activate
 neighbor 10.1.1.6 send-community
 neighbor 10.1.1.6 route-reflector-client
 neighbor 10.1.1.7 activate
 neighbor 10.1.1.7 send-community
 neighbor 10.1.1.7 route-reflector-client
 neighbor 10.1.1.8 activate
 neighbor 10.1.1.8 send-community
 neighbor 10.1.1.8 route-reflector-client
 no auto-summary
 no synchronization
 network 10.1.1.11 mask 255.255.255.255
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.1.1.1 activate
 neighbor 10.1.1.1 send-community both
 neighbor 10.1.1.1 route-reflector-client
 neighbor 10.1.1.2 activate
 neighbor 10.1.1.2 send-community both
 neighbor 10.1.1.2 route-reflector-client
 neighbor 10.1.1.3 activate
 neighbor 10.1.1.3 send-community both
 neighbor 10.1.1.3 route-reflector-client
 neighbor 10.1.1.4 activate
 neighbor 10.1.1.4 send-community both
 neighbor 10.1.1.4 route-reflector-client
 neighbor 10.1.1.5 activate
 neighbor 10.1.1.5 send-community both
 neighbor 10.1.1.5 route-reflector-client
 neighbor 10.1.1.6 activate
 neighbor 10.1.1.6 send-community extended
 neighbor 10.1.1.6 route-reflector-client
 neighbor 10.1.1.7 activate
 neighbor 10.1.1.7 send-community both
 neighbor 10.1.1.7 route-reflector-client
 neighbor 10.1.1.8 activate
 neighbor 10.1.1.8 send-community both
 neighbor 10.1.1.8 route-reflector-client
 exit-address-family
!
!
access-list 1 permit 10.1.1.0 0.0.0.255
!
mpls ldp router-id Loopback0 force
!



MPLS-P-2 ************************************************

!
ip cef
!
mpls label protocol ldp
mpls ldp neighbor 10.1.1.1 password cisco
mpls ldp neighbor 10.1.1.2 password cisco
mpls ldp neighbor 10.1.1.3 password cisco
mpls ldp neighbor 10.1.1.4 password cisco
mpls ldp neighbor 10.1.1.5 password cisco
mpls ldp neighbor 10.1.1.6 password cisco
mpls ldp neighbor 10.1.1.7 password cisco
mpls ldp neighbor 10.1.1.8 password cisco
!
interface Loopback0
 ip address 10.1.1.22 255.255.255.255
!
interface Ethernet1/0
 description # To PE1 e1/1 #
 ip address 192.168.1.33 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet1/1
 description # To PE2 e1/1 #
 ip address 192.168.1.37 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet1/2
 description # To PE3 e1/1 #
 ip address 192.168.1.41 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet1/3
 description # To PE4 e1/1 #
 ip address 192.168.1.45 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet2/0
 description # To PE8 e1/1 #
 ip address 192.168.1.49 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet2/1
 description # To PE7 e1/1 #
 ip address 192.168.1.53 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet2/2
 description # To PE6 e1/1 #
 ip address 192.168.1.57 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
interface Ethernet2/3
 description # To PE5 e1/1 #
 ip address 192.168.1.61 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 mpls ip
!
router ospf 1
 router-id 10.1.1.22
 log-adjacency-changes
 max-metric router-lsa on-startup wait-for-bgp
 max-metric router-lsa on-startup 360
 timers throttle lsa all 0 20 5000
 timers lsa arrival 15
 timers pacing flood 15
 timers throttle spf 50 50 5000
 ispf
 area 0 authentication message-digest
 network 10.1.1.22 0.0.0.0 area 0
 network 192.168.1.33 0.0.0.0 area 0
 network 192.168.1.37 0.0.0.0 area 0
 network 192.168.1.41 0.0.0.0 area 0
 network 192.168.1.45 0.0.0.0 area 0
 network 192.168.1.49 0.0.0.0 area 0
 network 192.168.1.53 0.0.0.0 area 0
 network 192.168.1.55 0.0.0.0 area 0
 network 192.168.1.59 0.0.0.0 area 0
!
router bgp 100
 bgp cluster-id 12
 bgp log-neighbor-changes
 neighbor 10.1.1.1 remote-as 100
 neighbor 10.1.1.1 password cisco
 neighbor 10.1.1.1 update-source Loopback0
 neighbor 10.1.1.2 remote-as 100
 neighbor 10.1.1.2 password cisco
 neighbor 10.1.1.2 update-source Loopback0
 neighbor 10.1.1.3 remote-as 100
 neighbor 10.1.1.3 password cisco
 neighbor 10.1.1.3 update-source Loopback0
 neighbor 10.1.1.4 remote-as 100
 neighbor 10.1.1.4 password cisco
 neighbor 10.1.1.4 update-source Loopback0
 neighbor 10.1.1.5 remote-as 100
 neighbor 10.1.1.5 password cisco
 neighbor 10.1.1.5 update-source Loopback0
 neighbor 10.1.1.6 remote-as 100
 neighbor 10.1.1.6 password cisco
 neighbor 10.1.1.6 update-source Loopback0
 neighbor 10.1.1.7 remote-as 100
 neighbor 10.1.1.7 password cisco
 neighbor 10.1.1.7 update-source Loopback0
 neighbor 10.1.1.8 remote-as 100
 neighbor 10.1.1.8 password cisco
 neighbor 10.1.1.8 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.1.1.1 activate
 neighbor 10.1.1.1 send-community
 neighbor 10.1.1.1 route-reflector-client
 neighbor 10.1.1.2 activate
 neighbor 10.1.1.2 send-community
 neighbor 10.1.1.2 route-reflector-client
 neighbor 10.1.1.3 activate
 neighbor 10.1.1.3 send-community
 neighbor 10.1.1.3 route-reflector-client
 neighbor 10.1.1.4 activate
 neighbor 10.1.1.4 send-community
 neighbor 10.1.1.4 route-reflector-client
 neighbor 10.1.1.5 activate
 neighbor 10.1.1.5 send-community
 neighbor 10.1.1.5 route-reflector-client
 neighbor 10.1.1.6 activate
 neighbor 10.1.1.6 send-community
 neighbor 10.1.1.6 route-reflector-client
 neighbor 10.1.1.7 activate
 neighbor 10.1.1.7 send-community
 neighbor 10.1.1.7 route-reflector-client
 neighbor 10.1.1.8 activate
 neighbor 10.1.1.8 send-community
 neighbor 10.1.1.8 route-reflector-client
 no auto-summary
 no synchronization
 network 10.1.1.22 mask 255.255.255.255
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.1.1.1 activate
 neighbor 10.1.1.1 send-community both
 neighbor 10.1.1.1 route-reflector-client
 neighbor 10.1.1.2 activate
 neighbor 10.1.1.2 send-community both
 neighbor 10.1.1.2 route-reflector-client
 neighbor 10.1.1.3 activate
 neighbor 10.1.1.3 send-community both
 neighbor 10.1.1.3 route-reflector-client
 neighbor 10.1.1.4 activate
 neighbor 10.1.1.4 send-community both
 neighbor 10.1.1.4 route-reflector-client
 neighbor 10.1.1.5 activate
 neighbor 10.1.1.5 send-community both
 neighbor 10.1.1.5 route-reflector-client
 neighbor 10.1.1.6 activate
 neighbor 10.1.1.6 send-community extended
 neighbor 10.1.1.6 route-reflector-client
 neighbor 10.1.1.7 activate
 neighbor 10.1.1.7 send-community both
 neighbor 10.1.1.7 route-reflector-client
 neighbor 10.1.1.8 activate
 neighbor 10.1.1.8 send-community both
 neighbor 10.1.1.8 route-reflector-client
 exit-address-family
!
access-list 1 permit 10.1.1.0 0.0.0.255
!
mpls ldp router-id Loopback0
!



### All configure have been proved, it work ###